flashplugin-nonfree sur Gutsy : un paquet fonctionnel dans les dépôts -proposed

Désolée si cette info a déjà été publiée ailleurs, sur d’autres blogs ou pages de tutoriel. Je n’ai pas fait de recherche et n’en ferai pas pour le moment. Parfois certaines choses de la vie sont plus importantes et demandent plus d’attention.

flashplugin-nonfree ne fonctionnait pas sur Gutsy depuis quelque temps. Je l’avais remarqué en installant Gutsy sur l’ordi de Noël de mon fils aîné. Assez dur pour un ado, mais il avait gentiment accepté d’attendre une solution officielle plutôt que de mettre en place une solution temporaire. Il a été patient, mais hier il a fallu que je m’y attelle ^^

J’avais suivi de loin le rapport de bug et un sujet sur UF. Une version fonctionnelle de flashplugin-nonfree a été « uploadée » dans les dépôt -proposed. Voici la procédure qui a fonctionné sur son install 32-bits :

  • Purger complètement le paquet installé précédemment (celui qui ne fonctionne pas, voir le rapport de bug et le sujet sur UF pour les explications du pourquoi et du comment). Sur la machine de mon fiston, j’ai utilisé synaptic, il fait ses updates/upgrades avec update-manager et synaptic. Utilisez apt-get ou aptitude si ce sont vos gestionnaires de paquets préférés.
  • Editez le fichier /etc/apt/sources.list et ajoutez cette ligne :

    # Proposed
    deb http://archive.ubuntu.com/ubuntu/ gutsy-proposed main restricted universe multiverse
  • Rechargez le fichier sources.list (avec synaptic, ou sudo apt-get update ou sudo aptitude update) et installez flashplugin-nonfree
  • Redémarrez votre navigateur (testé avec firefox et epiphany sur YouTube)
aptitude show flashplugin-nonfree
Paquet : flashplugin-nonfree
État: installé
Automatiquement installé: oui
Version : 9.0.48.0.2+really0ubuntu12.1
Priorité : optionnel
Section : contrib/web
Responsable : Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
Taille décompressée : 160k
Dépend: debconf | debconf-2.0, wget, libgtk2.0-0, fontconfig, libxt6, libxext6,
         libatk1.0-0, libc6, libcairo2, libexpat1, libfontconfig1, libfreetype6,
         libglib2.0-0, libice6, libpango1.0-0, libpng12-0, libsm6, libx11-6,
         libxau6, libxcursor1, libxdmcp6, libxfixes3, libxi6, libxinerama1,
         libxrandr2, libxrender1, zlib1g
Suggère: firefox, konqueror-nsplugins, x-ttcidfont-conf, msttcorefonts,
          ttf-bitstream-vera | ttf-dejavu, ttf-xfree86-nonfree, xfs (>=
          1:1.0.1-5)
Est en conflit: flashplugin (< 6), xfs (< 1:1.0.1-5), flashplayer-mozilla
Remplace: flashplugin (< 6)
Description : Adobe Flash Player plugin installer
 This package will download the Flash Player from Adobe.  It is a
 Netscape/Mozilla type plugin.  Any browser based on Netscape or Mozilla can use
 the Flash plugin.  This package currently supports the following browsers:
 Mozilla, Mozilla-Firefox, Firefox, Iceweasel, and Iceape.  Also Galeon and
 Epiphany can use the Flash plugin.  Konqueror can also use the Flash plugin if
 konqueror-nsplugins is installed. 
 
 WARNING: Installing this Ubuntu package causes the Adobe flash plugin to be
 downloaded from www.adobe.com.  The distribution license of the Adobe flash
 plugin is available at www.adobe.com.  Installing this Ubuntu package implies
 that you have accepted the terms of that license. 
 
 Homepage: http://wiki.ubuntu.com/FlashPlayer9

Avertissement

Les dépôts -proposed sont pour des TESTS, alors veuillez les commenter après avoir installé flash.

D’après le rapport de bug, il semble que le paquet soit disponible pour Feisty, mais pas pour des versions précédentes d’Ubuntu (du fait de problèmes avec flash 7).

En espérant avoir été utile :)

English version here.

About these ads

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

Suivre

Recevez les nouvelles publications par mail.

%d bloggers like this: